package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\bhttps?:\/\/[^\s]*`)
var str = `http://www.regex101.com https://www.stachoverflow.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}