$re = '/\bhttps?:\/\/[^\s]*/im';
$str = 'http://www.regex101.com https://www.stachoverflow.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);