package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#([^,\s]+)#`)
var str = `"Items:#1 #1000#,#2000#"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}