using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(n)(?=(n))";
string substitution = @"\1;";
string input = @"nnnn";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}