const regex = /(n)(?=(n))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(n)(?=(n))', 'gm')
const str = `nnnn`;
const subst = `\1;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);