#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\S+\.(?:png|jpe?g|gif|bmp|mp4|avi|flv)\b"
Local $sString = "/mnt/data/Content:" & @CRLF & _
"ManifestFile.txt kompass-tags_e2d5dac5ba548a1206b5d40f58e448e4 tmp_content" & @CRLF & _
"default_55a655f340908dce55d10a191b6a0140 price-tags_b3c756dda783ad0691163a900fb5fe15" & @CRLF & _
"" & @CRLF & _
"/mnt/data/Content/default_55a655f340908dce55d10a191b6a0140:" & @CRLF & _
"LayoutFile_34450b33c8b44af409abb057ddedfdfe.txt blank_decommissioned.jpeg tmp_content" & @CRLF & _
"ManifestFile.txt blank_unregistered.png" & @CRLF & _
"" & @CRLF & _
"/mnt/data/Content/default_55a655f340908dce55d10a191b6a0140/tmp_content:" & @CRLF & _
"" & @CRLF & _
"/mnt/data/Content/kompass-tags_e2d5dac5ba548a1206b5d40f58e448e4:" & @CRLF & _
"0001111084948-kompass-LARGE.avi 0076738703404-kompass-LARGE.png LayoutFile_7c1b3793e49204982e0e41923303c17b.txt" & @CRLF & _
"0001111087321-kompass-LARGE.jpg 0076738703419-kompass-LARGE.mp4 ManifestFile.txt" & @CRLF & _
"0001111087325-kompass-LARGE.png 0076738703420-kompass-LARGE.png tmp_content" & @CRLF & _
"" & @CRLF & _
"/mnt/data/Content/kompass-tags_e2d5dac5ba548a1206b5d40f58e448e4/tmp_content:" & @CRLF & _
"" & @CRLF & _
"/mnt/data/Content/price-tags_b3c756dda783ad0691163a900fb5fe15:" & @CRLF & _
"0001111084948-consumer-large.png 0076738703404-consumer-large.png LayoutFile_a694b1e05d08705aaf4dd589ac61d493.txt" & @CRLF & _
"0001111087321-consumer-large.png 0076738703419-consumer-large.avi ManifestFile.txt" & @CRLF & _
"0001111087325-consumer-large.mp4 0076738703420-consumer-large.png tmp_content" & @CRLF & _
"" & @CRLF & _
"/mnt/data/Content/price-tags_b3c756dda783ad0691163a900fb5fe15/tmp_content:" & @CRLF & _
"" & @CRLF & _
"/mnt/data/Content/tmp_content:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")