# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\S+\.(?:png|jpe?g|gif|bmp|mp4|avi|flv)\b"
test_str = ("/mnt/data/Content:\n"
"ManifestFile.txt kompass-tags_e2d5dac5ba548a1206b5d40f58e448e4 tmp_content\n"
"default_55a655f340908dce55d10a191b6a0140 price-tags_b3c756dda783ad0691163a900fb5fe15\n\n"
"/mnt/data/Content/default_55a655f340908dce55d10a191b6a0140:\n"
"LayoutFile_34450b33c8b44af409abb057ddedfdfe.txt blank_decommissioned.jpeg tmp_content\n"
"ManifestFile.txt blank_unregistered.png\n\n"
"/mnt/data/Content/default_55a655f340908dce55d10a191b6a0140/tmp_content:\n\n"
"/mnt/data/Content/kompass-tags_e2d5dac5ba548a1206b5d40f58e448e4:\n"
"0001111084948-kompass-LARGE.avi 0076738703404-kompass-LARGE.png LayoutFile_7c1b3793e49204982e0e41923303c17b.txt\n"
"0001111087321-kompass-LARGE.jpg 0076738703419-kompass-LARGE.mp4 ManifestFile.txt\n"
"0001111087325-kompass-LARGE.png 0076738703420-kompass-LARGE.png tmp_content\n\n"
"/mnt/data/Content/kompass-tags_e2d5dac5ba548a1206b5d40f58e448e4/tmp_content:\n\n"
"/mnt/data/Content/price-tags_b3c756dda783ad0691163a900fb5fe15:\n"
"0001111084948-consumer-large.png 0076738703404-consumer-large.png LayoutFile_a694b1e05d08705aaf4dd589ac61d493.txt\n"
"0001111087321-consumer-large.png 0076738703419-consumer-large.avi ManifestFile.txt\n"
"0001111087325-consumer-large.mp4 0076738703420-consumer-large.png tmp_content\n\n"
"/mnt/data/Content/price-tags_b3c756dda783ad0691163a900fb5fe15/tmp_content:\n\n"
"/mnt/data/Content/tmp_content:")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.