#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<=\[)\w+)|(\w+(?=\=))|((?<=\=)\d+)|((?<=\=)\[\d,\d\])|((?<=\=)\[\d,\d,\d,\d])|(\"[a-zA-Z\._0-9\s]+\")|(\'[a-zA-Z\._0-9\s]+\')"
Local $sString = "//完整代码匹配测试" & @CRLF & _
"[sprite file="1.png" index=2 rect=[0,0,0,0] pos=[0,2]][sprite file='2.png' index=2 rect=[0,0,0,0]] //这是注释 /comment abcdefg" & @CRLF & _
"//宏名称单元测试" & @CRLF & _
"[bg]" & @CRLF & _
" [bg]" & @CRLF & _
"[ bg]" & @CRLF & _
"" & @CRLF & _
"//字符串参数值单元测试" & @CRLF & _
"="abc"" & @CRLF & _
"="ABC"" & @CRLF & _
"="_abcABC"" & @CRLF & _
"="_abcABC.png"" & @CRLF & _
"="_abcABC special.png" " & @CRLF & _
"" & @CRLF & _
"//参数名单元测试" & @CRLF & _
"[bg index=2]" & @CRLF & _
"[bg index=2]" & @CRLF & _
"[bg index =2]" & @CRLF & _
"" & @CRLF & _
"//int参数值单元测试" & @CRLF & _
"[bg index=54687]" & @CRLF & _
"[bg index=1 index2=26764]" & @CRLF & _
"//pos_t 4位长度的int数组测试" & @CRLF & _
"[bg index=0 pos=[1,2,3,4]]" & @CRLF & _
"//匹配坐标型 pos_t指长度为2的整数型数组,分别为横坐标x、纵坐标y" & @CRLF & _
"[bg index=0 pos=[0,2]" & @CRLF & _
"//abcdd asd [vb ] "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")