const regex = new RegExp('((?<=\\[)\\w+)|(\\w+(?=\\=))|((?<=\\=)\\d+)|((?<=\\=)\\[\\d,\\d\\])|((?<=\\=)\\[\\d,\\d,\\d,\\d])|(\\"[a-zA-Z\\._0-9\\s]+\\")|(\\\\'[a-zA-Z\\._0-9\\s]+\\\\')', 'gm')
const str = `//完整代码匹配测试
[sprite file="1.png" index=2 rect=[0,0,0,0] pos=[0,2]][sprite file='2.png' index=2 rect=[0,0,0,0]] //这是注释 /comment abcdefg
//宏名称单元测试
[bg]
[bg]
[ bg]
//字符串参数值单元测试
="abc"
="ABC"
="_abcABC"
="_abcABC.png"
="_abcABC special.png"
//参数名单元测试
[bg index=2]
[bg index=2]
[bg index =2]
//int参数值单元测试
[bg index=54687]
[bg index=1 index2=26764]
//pos_t 4位长度的int数组测试
[bg index=0 pos=[1,2,3,4]]
//匹配坐标型 pos_t指长度为2的整数型数组,分别为横坐标x、纵坐标y
[bg index=0 pos=[0,2]
//abcdd asd [vb ] `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}