#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<img *src= *"(?<img>[^"]*)""
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html>" & @CRLF & _
"<head>" & @CRLF & _
" <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />" & @CRLF & _
" <title>Dimitri Smeets</title>" & @CRLF & _
" <link rel="stylesheet" href="css/style.css" type="text/css" charset="utf-8" /> " & @CRLF & _
"</head>" & @CRLF & _
"" & @CRLF & _
"<body>" & @CRLF & _
" <span id="background"></span>" & @CRLF & _
" <div id="page">" & @CRLF & _
" <div id="sidebar">" & @CRLF & _
" <a href="index.html">The selected works of Dimitri Smeets</a>" & @CRLF & _
" </p> " & @CRLF & _
" " & @CRLF & _
" <!-- /#logo -->" & @CRLF & _
" <ul id="navigation">" & @CRLF & _
"" & @CRLF & _
" <li><a href="about.html">About</a></li>" & @CRLF & _
" <li><a href="games.html">games</a></li>" & @CRLF & _
" <li><a href="contact.html">Contact </a></li>" & @CRLF & _
" <li></li>" & @CRLF & _
" </ul> <!-- /#navigation -->" & @CRLF & _
" <ul id="connect">" & @CRLF & _
" <li><a href="https://nl-nl.facebook.com/d3ullist" target="_blank" class="facebook"></a></li>" & @CRLF & _
" <li><a href="http://twitter.com/D3ullist" target="_blank" class="twitter"></a></li>" & @CRLF & _
" <li></li>" & @CRLF & _
" </ul> <!-- /#connect -->" & @CRLF & _
" <div class="footer"></div> <!-- /.footer -->" & @CRLF & _
" </div> <!-- /#sidebar -->" & @CRLF & _
" " & @CRLF & _
" <div id="contents">" & @CRLF & _
" <span class="header"></span>" & @CRLF & _
" <h1 align="center">The portfolio site of Dimitri Smeets </h1>" & @CRLF & _
" <p><center>" & @CRLF & _
" <p><img src="images/IMG-20131110-WA0005.jpg" width="206" height="241"></p>" & @CRLF & _
" <p>I am a student at the Grafish lyceum rotterdam where I study Game Development.</p>" & @CRLF & _
" <p>I have experience with several program languages such as:</p>" & @CRLF & _
" <p>C#, javascript, c++ </p>" & @CRLF & _
" <p>And am still developing my skills in these languages</p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" </center></p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" </div> " & @CRLF & _
" <!-- /#contents -->" & @CRLF & _
" </div> <!-- /#page -->" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")