re = /<img *src= *"(?<img>[^"]*)"/
str = '<!DOCTYPE html>
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Dimitri Smeets</title>
<link rel="stylesheet" href="css/style.css" type="text/css" charset="utf-8" />
</head>
<body>
<span id="background"></span>
<div id="page">
<div id="sidebar">
<a href="index.html">The selected works of Dimitri Smeets</a>
</p>
<!-- /#logo -->
<ul id="navigation">
<li><a href="about.html">About</a></li>
<li><a href="games.html">games</a></li>
<li><a href="contact.html">Contact </a></li>
<li></li>
</ul> <!-- /#navigation -->
<ul id="connect">
<li><a href="https://nl-nl.facebook.com/d3ullist" target="_blank" class="facebook"></a></li>
<li><a href="http://twitter.com/D3ullist" target="_blank" class="twitter"></a></li>
<li></li>
</ul> <!-- /#connect -->
<div class="footer"></div> <!-- /.footer -->
</div> <!-- /#sidebar -->
<div id="contents">
<span class="header"></span>
<h1 align="center">The portfolio site of Dimitri Smeets </h1>
<p><center>
<p><img src="images/IMG-20131110-WA0005.jpg" width="206" height="241"></p>
<p>I am a student at the Grafish lyceum rotterdam where I study Game Development.</p>
<p>I have experience with several program languages such as:</p>
<p>C#, javascript, c++ </p>
<p>And am still developing my skills in these languages</p>
<p> </p>
</center></p>
<p> </p>
<p> </p>
</div>
<!-- /#contents -->
</div> <!-- /#page -->
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end