import re
regex = re.compile(r"(.*)((core\/)?\/misc\/drupal\.js)")
test_str = ("installations/si/drupal-4test/misc/drupal.js\n"
"installations/si/drupal-8.1.0/core/misc/drupal.js\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")