package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"\s*totalWinAmount\s*"\s*:\s*(?<totalWinAmount>\d*)`)
var str = `"totalWinAmount":100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}