$re = '/"\s*totalWinAmount\s*"\s*:\s*(?<totalWinAmount>\d*)/m';
$str = '"totalWinAmount":100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);