using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{text\}.*?(?=\{text\}|$)";
string input = @"{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf
{text} dklj gjkld fjg ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}