$re = '/\{text\}.*?(?=\{text\}|$)/m';
$str = '{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf {text} asdasdasda {text} lklklklk
{text} dklj gjkld fjg {text} sdf sdf sdf sdf
{text} dklj gjkld fjg ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);