const regex = /([^*\/][^*\/][^*\/]*)(?=\/\*.*?\*\/|$)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^*\\\/][^*\\\/][^*\\\/]*)(?=\\\/\\*.*?\\*\\\/|$)', 'gs')
const str = `/*dfsdfd*/
.class-n {
}
/**/
.class-1 {
font-family: 'SourceCodePro';
font-size: 16px;
line-height: 18px;
}
/*o I want to select everything but t
hese cmments */
ddd
.class-2 {
background-color: rgb(40, 40, 40);
border: 1px solid rgb(20, 20, 20);
padding: 10px 15px 10px 15px;
}
/*Single line */
/* Multiline
Comment */
ghjghjghj
/* Multiline
Comment */`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}