$re = '/([^*\/][^*\/][^*\/]*)(?=\/\*.*?\*\/|$)/s';
$str = '/*dfsdfd*/
.class-n {
}
/**/
.class-1 {
font-family: \'SourceCodePro\';
font-size: 16px;
line-height: 18px;
}
/*o I want to select everything but t
hese cmments */
ddd
.class-2 {
background-color: rgb(40, 40, 40);
border: 1px solid rgb(20, 20, 20);
padding: 10px 15px 10px 15px;
}
/*Single line */
/* Multiline
Comment */
ghjghjghj
/* Multiline
Comment */';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);