import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Registrant's address:).*(?=(?:Registrar:|Registered:))";
final String string = "Domain name:\n"
+ " amazon.co.uk\n\n"
+ "Registrant:\n"
+ " Amazon Europe Holding Technologies SCS\n\n"
+ "Registrant type:\n"
+ " Unknown\n\n"
+ "Registrant's address:\n"
+ " 65 boulevard G-D. Charlotte\n"
+ " Luxembourg City\n"
+ " Luxembourg\n"
+ " LU-1311\n"
+ " Luxembourg\n\n"
+ "Registrar:\n"
+ " Amazon.com [Tag = AMAZON-COM]\n"
+ " URL: http://www.amazon.com\n\n"
+ "Relevant dates:\n"
+ " Registered on: before Aug-1996\n"
+ " Expiry date: 05-Dec-2020\n"
+ " Last updated: 23-Oct-2013";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}