$re = '/(?<=Registrant\'s address:).*(?=(?:Registrar:|Registered:))/s';
$str = 'Domain name:
amazon.co.uk
Registrant:
Amazon Europe Holding Technologies SCS
Registrant type:
Unknown
Registrant\'s address:
65 boulevard G-D. Charlotte
Luxembourg City
Luxembourg
LU-1311
Luxembourg
Registrar:
Amazon.com [Tag = AMAZON-COM]
URL: http://www.amazon.com
Relevant dates:
Registered on: before Aug-1996
Expiry date: 05-Dec-2020
Last updated: 23-Oct-2013';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);