import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(feature)\\/\\d+$)|^(hotfix|release)\\/\\d+\\.\\d+\\.\\d+$|^develop$|^master$";
final String string = "feature\n"
+ "feature/\n"
+ "feature/asdf\n"
+ "feature/123\n"
+ "bugfix\n"
+ "bugfix/\n"
+ "bugfix/asdf\n"
+ "bugfix/123\n"
+ "temp\n"
+ "temp/\n"
+ "temp/123\n"
+ "temp/abc\n"
+ "temp/123abc\n"
+ "temp/123.abc\n"
+ "temp/123.123\n"
+ "hotfix\n"
+ "hotfix/\n"
+ "hotfix/abc\n"
+ "hotfix/123\n"
+ "hotfix/1.0.0\n"
+ "hotfix/11.11.11\n"
+ "release\n"
+ "release/\n"
+ "release/abc\n"
+ "release/123\n"
+ "release/1.0.0\n"
+ "release/11.11.11\n"
+ "support\n"
+ "support/\n"
+ "support/abc\n"
+ "support/123\n"
+ "support/1.0.0\n"
+ "support/11.11.11\n"
+ "support/1.x\n"
+ "develop\n"
+ "master";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}