import re
regex = re.compile(r"(?i)^Link\s+to\s+(?<keyword>[a-z ]+) from (?<name>.*?)(?:\s+shared\s+(?<time>[a-z]+))?$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("link to connect link from sandeep akula\n"
"link to sharepoint git from sapna\n"
"link to sharepoint git from sapna grover shared yesterday\n\n"
"sharepoint git link form sapna shared yesterday")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")