re = /(?i)^Link\s+to\s+(?<keyword>[a-z ]+) from (?<name>.*?)(?:\s+shared\s+(?<time>[a-z]+))?$/im
str = 'link to connect link from sandeep akula
link to sharepoint git from sapna
link to sharepoint git from sapna grover shared yesterday
sharepoint git link form sapna shared yesterday'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end