$re = '/(?<=EUR)\n\n(.*?(?=\s))\s(.*?(?=\s))\s(.*?(?=\s))\s(.*?(?=\s))\s(.*?(?=\s))/';
$str = '01 9768332B SPC Tablet 10.1" IPS Gravity Pro 3GB RAM 32GB Blan 1,00 101,99 0,00 101,99
Base Imponible +LPI IVA Cuota IVA Recargo Cuota Recargo Importe Total: 104,99 EUR
104,99 0,00 0,00 0,00 0,00
Forma de pago: RECIBO DOMICILIADO A 20 D-B2B Vencimientos: 26/11/2020 104,99 EUR
Dirección de giro: ES68 2100 4566 22 0200110380
Días de pago: COBRO TODOS DIAS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);