import re
regex = re.compile(r"(?<=EUR)\n\n(.*?(?=\s))\s(.*?(?=\s))\s(.*?(?=\s))\s(.*?(?=\s))\s(.*?(?=\s))")
test_str = ("01 9768332B SPC Tablet 10.1\" IPS Gravity Pro 3GB RAM 32GB Blan 1,00 101,99 0,00 101,99\n\n"
"Base Imponible +LPI IVA Cuota IVA Recargo Cuota Recargo Importe Total: 104,99 EUR\n\n"
"104,99 0,00 0,00 0,00 0,00\n\n"
"Forma de pago: RECIBO DOMICILIADO A 20 D-B2B Vencimientos: 26/11/2020 104,99 EUR\n"
"Dirección de giro: ES68 2100 4566 22 0200110380\n"
"Días de pago: COBRO TODOS DIAS")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")