import re
regex = re.compile(r"^\w+\s\d+\s\d+:\d+:\d+\ssvr\-.*\-nac-(01|02)\s", flags=re.MULTILINE)
test_str = ("May 20 10:59:30 svr-orw-nac-01 2020-05-20 17:59:30,646\n"
"May 20 11:01:01 svr-ies-nac-02 2020-05-20 18:01:01,389")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")