#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\-?\(.*\))"
Local $sString = "363" & @CRLF & _
"00:22:09,395 --> 00:22:11,996" & @CRLF & _
" Because he did only" & @CRLF & _
" meet me the once." & @CRLF & _
"" & @CRLF & _
"364" & @CRLF & _
"00:22:11,998 --> 00:22:13,597" & @CRLF & _
" Perhaps I could..." & @CRLF & _
"" & @CRLF & _
"365" & @CRLF & _
"00:22:20,105 --> 00:22:21,772" & @CRLF & _
" (CLAMOURING)" & @CRLF & _
"" & @CRLF & _
"366" & @CRLF & _
"00:22:21,774 --> 00:22:25,009" & @CRLF & _
" (INDISTINCT ANNOUNCEMENT" & @CRLF & _
" OVER PA)" & @CRLF & _
"" & @CRLF & _
"367" & @CRLF & _
"00:22:55,340 --> 00:22:58,509" & @CRLF & _
" (INDISTINCT ANNOUNCEMENT" & @CRLF & _
" OVER PA)" & @CRLF & _
"" & @CRLF & _
"368" & @CRLF & _
"00:23:10,655 --> 00:23:11,389" & @CRLF & _
" SARAH: Excuse me." & @CRLF & _
"" & @CRLF & _
"369" & @CRLF & _
"00:23:11,391 --> 00:23:14,225" & @CRLF & _
" Were there any men flying" & @CRLF & _
" alone on this fligh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")