import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\bSECOND\\sLEVEL(\\n\\s+.*)*Dining:)(.*\\b)";
final String string = " MAIN LEVEL\n"
+ " Entrance: 11\n"
+ " Living: 22\n"
+ " Dining: 333\n"
+ " Kitchen: 444\n"
+ " Family: 555\n"
+ " Bedrooms: 666\n"
+ " Den: 777\n"
+ " Full Bath: 888\n"
+ " Part Bath: 999\n"
+ " Laundry: 000\n"
+ " Other 1 Name: FuckMe\n"
+ " Other 1 Count: 6969\n"
+ " Other 2 Name: Bsother2\n"
+ " Other 2 Count: 9696\n"
+ " Other 3 Name: 3\n"
+ " Other 3 Count: 2\n\n"
+ " SECOND LEVEL\n"
+ " Entrance: 1111\n"
+ " Living: 2222\n"
+ " Dining: 3333\n"
+ " Kitchen: 4444\n"
+ " Family: 5555\n"
+ " Bedrooms: 6666\n"
+ " Den: 7777\n"
+ " Full Bath: 8888\n"
+ " Part Bath: 9999\n"
+ " Laundry: 0000\n"
+ " Other 1 Name: Bsother\n"
+ " Other 1 Count: 4\n"
+ " Other 2 Name: Bsother2\n"
+ " Other 2 Count: 5\n"
+ " Other 3 Name: 3\n"
+ " Other 3 Count: 9\n\n"
+ " THIRD LEVEL\n"
+ " Entrance: 3333\n"
+ " Living: 334\n"
+ " Dining: 3332\n"
+ " Kitchen: 33336\n"
+ " Family: 33332\n"
+ " Bedrooms: 33338\n"
+ " Den: 3331336\n"
+ " Full Bath: 363933\n"
+ " Part Bath: 3655733\n"
+ " Laundry: 335525\n"
+ " Other 1 Name: Bsother\n"
+ " Other 1 Count: 2\n"
+ " Other 2 Name: Bsother2\n"
+ " Other 2 Count: 2\n"
+ " Other 3 Name: 3\n"
+ " Other 3 Count: 2\n\n"
+ " OTHER LEVEL\n"
+ " Level Name: Basement\n"
+ " Entrance: 1\n"
+ " Living: 1\n"
+ " Dining: 2\n"
+ " Kitchen: 1\n"
+ " Family: 1\n"
+ " Bedrooms: 1\n"
+ " Den: 1\n"
+ " Full Bath: 1\n"
+ " Part Bath: 1\n"
+ " Laundry: 1 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}