$re = '/(?:\bSECOND\sLEVEL(\n\s+.*)*Dining:)(.*\b)/';
$str = ' MAIN LEVEL
Entrance: 11
Living: 22
Dining: 333
Kitchen: 444
Family: 555
Bedrooms: 666
Den: 777
Full Bath: 888
Part Bath: 999
Laundry: 000
Other 1 Name: FuckMe
Other 1 Count: 6969
Other 2 Name: Bsother2
Other 2 Count: 9696
Other 3 Name: 3
Other 3 Count: 2
SECOND LEVEL
Entrance: 1111
Living: 2222
Dining: 3333
Kitchen: 4444
Family: 5555
Bedrooms: 6666
Den: 7777
Full Bath: 8888
Part Bath: 9999
Laundry: 0000
Other 1 Name: Bsother
Other 1 Count: 4
Other 2 Name: Bsother2
Other 2 Count: 5
Other 3 Name: 3
Other 3 Count: 9
THIRD LEVEL
Entrance: 3333
Living: 334
Dining: 3332
Kitchen: 33336
Family: 33332
Bedrooms: 33338
Den: 3331336
Full Bath: 363933
Part Bath: 3655733
Laundry: 335525
Other 1 Name: Bsother
Other 1 Count: 2
Other 2 Name: Bsother2
Other 2 Count: 2
Other 3 Name: 3
Other 3 Count: 2
OTHER LEVEL
Level Name: Basement
Entrance: 1
Living: 1
Dining: 2
Kitchen: 1
Family: 1
Bedrooms: 1
Den: 1
Full Bath: 1
Part Bath: 1
Laundry: 1 ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);