const regex = /([\w\s]+)(?:[\s\.]*)([\d:]+)(?:[\s\-]*)([\w]+)(?:[\s:]*)([\s\S]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w\\s]+)(?:[\\s\\.]*)([\\d:]+)(?:[\\s\\-]*)([\\w]+)(?:[\\s:]*)([\\s\\S]*)', 'g')
const str = `11 jan. 22:20 - Dam: Ik zal d'r zijn`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}