re = /([\w\s]+)(?:[\s\.]*)([\d:]+)(?:[\s\-]*)([\w]+)(?:[\s:]*)([\s\S]*)/
str = '11 jan. 22:20 - Dam: Ik zal d\'r zijn'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end