const regex = /\s(?!\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(?!\\s)', 'g')
const str = `S O M E T E X T I W O U L D L I K E T O H I G H L I G H T`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);