$re = '/\s(?!\s)/';
$str = 'S O M E T E X T I W O U L D L I K E T O H I G H L I G H T';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;