package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9.]+)([kmbBtTqQ]*)`)
var str = `1234.567k`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}