use strict;
my $str = '<form-filter-field [isRequired]="isRequired" [inputField]="field.field" [readonly]="readonly" label="{{field.title||(field.name|uppercase)|translate}}" [formControl]="control"></form-filter-field>';
my $regex = qr/(?(DEFINE)(?<namepart>\w+))(?(DEFINE)(?<name>(?&namepart)(\.(?&namepart))*))(?(DEFINE)(?<helper>(?<hexpr>(?&sexpr))\|(?<hname>(?&namepart))))(?(DEFINE)(?<sexpr>(?&name)|\((?&expr)\)))(?(DEFINE)(?<expr>((?&or)|(?&helper))))(?(DEFINE)(?<or>(?<or1>(?&name))\|\|(?<or2>(?&expr))?))(?&or)/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}