$re = '/(?(DEFINE)(?<namepart>\w+))(?(DEFINE)(?<name>(?&namepart)(\.(?&namepart))*))(?(DEFINE)(?<helper>(?<hexpr>(?&sexpr))\|(?<hname>(?&namepart))))(?(DEFINE)(?<sexpr>(?&name)|\((?&expr)\)))(?(DEFINE)(?<expr>((?&or)|(?&helper))))(?(DEFINE)(?<or>(?<or1>(?&name))\|\|(?<or2>(?&expr))?))(?&or)/x';
$str = '<form-filter-field [isRequired]="isRequired" [inputField]="field.field" [readonly]="readonly" label="{{field.title||(field.name|uppercase)|translate}}" [formControl]="control"></form-filter-field>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);