$re = '/\<status\>(.*?)\</status\>/i';
$str = 'This is some long random text <status>This is the first status block</status> and some more text <status>and another block</status> and yet more <status>This is the last status block</status>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);