re = /\<status\>(.*?)\<\/status\>/i
str = 'This is some long random text <status>This is the first status block</status> and some more text <status>and another block</status> and yet more <status>This is the last status block</status>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end