$re = '/^(?=.*[a-zA-Z])(?=.*[0-9])[a-zA-Z0-9]*$/m';
$str = 'asdjkl
3456789
7788bnnn
hjjhkj789jkh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);