re = /^(?=.*[a-zA-Z])(?=.*[0-9])[a-zA-Z0-9]*$/m
str = 'asdjkl
3456789
7788bnnn
hjjhkj789jkh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end