using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<=\""birthDate\"": \"")(\d{4}-\d{2}-\d{2})(?=\"")\b";
string input = @"""birthDate"": ""2015-10-02""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}