$re = '/\b(?<=\"birthDate\": \")(\d{4}-\d{2}-\d{2})(?=\")\b/m';
$str = '"birthDate": "2015-10-02"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);