package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S+/)[^\s_]+_[^\s_/?]+(.*)`)
var str = `/asd/fdsadx/sadsa/ab_cd/myword?Id=953
/asd/fdsadx/sadsa/xx_yy?Id=953
/asd/fdsadx/sadsa/pp_qq/myword
/asd/fdsadx/sadsa/ab_cd
/asd/fdsadx/sadsa//myword?Id=953
/asd/fdsadx/sadsa/?Id=953
/asd/fdsadx/sadsa//myword
/asd/fdsadx/sadsa/`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}