const regex = new RegExp('^(\\S+/)[^\\s_]+_[^\\s_/?]+(.*)', 'gm')
const str = `/asd/fdsadx/sadsa/ab_cd/myword?Id=953
/asd/fdsadx/sadsa/xx_yy?Id=953
/asd/fdsadx/sadsa/pp_qq/myword
/asd/fdsadx/sadsa/ab_cd
/asd/fdsadx/sadsa//myword?Id=953
/asd/fdsadx/sadsa/?Id=953
/asd/fdsadx/sadsa//myword
/asd/fdsadx/sadsa/`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);