import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\s(\\d)\\s+(\\S.*?)\\s+(\\d)\\s+(\\S.*?)\\s+(\\d)\\s+(\\S.*?)\\s+(\\d)(?:\\s+(\\S.*))?$";
final String string = "YYYYYYYY 1 BBBBBB BBB BBBBBB 2 DDDDDD DDD DD 3 FFFFFF FFF FFF 4 ( HHHH HHH HHHHH)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}