const regex = /^.*?\s(\d)\s+(\S.*?)\s+(\d)\s+(\S.*?)\s+(\d)\s+(\S.*?)\s+(\d)(?:\s+(\S.*))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?\\s(\\d)\\s+(\\S.*?)\\s+(\\d)\\s+(\\S.*?)\\s+(\\d)\\s+(\\S.*?)\\s+(\\d)(?:\\s+(\\S.*))?$', 'gm')
const str = `YYYYYYYY 1 BBBBBB BBB BBBBBB 2 DDDDDD DDD DD 3 FFFFFF FFF FFF 4 ( HHHH HHH HHHHH)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}