package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Temp:([^,]+)`)
var str = `Temp:C5E501374D0343090957F7E5929E765C931F7D3EC7A96189FDA88549D54D9E4E5DB3FC1C2, adfsafd1242412,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}