const regex = /#(?:(\w+(?:\s+(?:\w+(?:\s+(?:\w+)?)?)?)?)|(.*)\s#)\s/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#(?:(\\w+(?:\\s+(?:\\w+(?:\\s+(?:\\w+)?)?)?)?)|(.*)\\s#)\\s', 'gi')
const str = `#test1 test2 #test3 test4 test5 #test6 test7 test8 test9 test10#test11 test12 #test13 test14 test15 test16 test17`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}