$re = '/#(?:(\w+(?:\s+(?:\w+(?:\s+(?:\w+)?)?)?)?)|(.*)\s#)\s/i';
$str = '#test1 test2 #test3 test4 test5 #test6 test7 test8 test9 test10#test11 test12 #test13 test14 test15 test16 test17';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);