package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]+$`)
var str = `aA4?asA8
A5V3asd,adwS5!
abacada`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}